Как настроить Самбу

Я интересно, если есть кто-то, кто знает, как настроить Самбу в следующей ситуации.

Я живу в доме, где все компьютеры находятся в локальной сети. В Windows я смог увидеть все мои соседи и компьютеры соседей и я могу открыть общую папку Мои соседи' (потому что у меня есть доступ к этому). В Windows все это возможно автоматически.

В Ubuntu (12.04) я вижу mahcines все мои соседи Mac и несколько компьютеров под управлением Windows в Сети Наутилус' "" разделе, но там, как правило, около 50 компьютеров в сети все время, так что большинство из них не показали. Я не могу найти например компьютер моего соседа.

Я не изменил любой конфигурации самбы еще. Что я должен сделать, чтобы увидеть все компьютеры в локальной сети?

+114
Wilf Rosenbaum 30 сент. 2017 г., 12:56:27
16 ответов

Мой вопрос был дан ответ на повторяющийся вопрос на serverfault (первый ответ). Я добавил:

HostKeyAlgorithms [email protected],[email protected],[email protected],[email protected],ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa,ssh-ДСС 

в ~/.по SSH/config файл

+972
digembok 03 февр. '09 в 4:24

Нет, потому что у каждой операционной системы разная. Если вам нужно установить внутри виртуальной машины и запустить операционную систему внутри другой.

+931
Tanveer Rana 27 мая 2014 г., 10:01:47

Вы бы для установки Windows 7 первая (поэтому он может загружаться с MBR), а затем установить Ubuntu параллельно с Windows. Установщик Wubi и я думаю, что есть возможность установить различные секции для двойной загрузки для Ubuntu

+901
templeorder 29 янв. 2019 г., 17:03:08

Ничего не предлагалось выше работали в моем случае (сервер Ubuntu 12.04 ЛТС). Что в итоге помогло положить в файл /и т. д./среды:

Значение lc_all=язык.В UTF-8
Язык=язык.В UTF-8

Почему-то отсутствует. Выходы для локали и других команд появился бы переменные были правильно определены. Иными словами, не брать на веру все базовые вещи, объявляется, где он должен быть объявлен.

+818
Someguywhocodes 20 окт. 2013 г., 9:35:24

Sendmail-это довольно древняя. В то время как некоторые люди считают, что это лучший почтовый сервер все написано, лично мне не понравится хоть немного.

Моя комбинация для отправки электронной почты от локальных пользователей к "внешним" mail адреса является постфикс и в BSD-mailx

Если вы хотите дать ему попробовать: суда apt-получить установку почтового сервера postfix в BSD-mailx.

Если вы не хотите получать электронную почту на этот хост, вы могли бы сделать постфикс немного более безопасным путем привязки его к localhost. Выполните команду sudo postconf -E 'в inet_interfaces = localhost в && судо сервис перезапустить постфикс.

+780
Speckled Ed 2 июл. 2017 г., 4:45:09

Создание .deb-пакеты с Checkinstall

http://www.howtoforge.com/howto_linux_debian_deb_checkinstall

Checkinstall - это хороший инструмент для создания простых .deb-пакеты, которые можно использовать в вашей локальной сети (например, если вам нужно установить одни и те же программы на несколько компьютеров под управлением Debian). Это позволяет компилировать и устанавливать программное обеспечение из источников, как и раньше, но с той разницей, что вы в конечном итоге с простой пакет Debian, который также означает, что вы можете легко удалить программу, вы просто составитель выполнении dpkg -Р!

+710
Christopher Porter 20 июн. 2019 г., 23:25:38

Это аналогичная ситуация, что я с моими процессорами Intel® 965GM. Моя система информация также показывает мою видеокарту как неизвестные в Ubuntu 11.10, и через некоторое время (спустя несколько дней я установил Ubuntu 11.10) мое единство 3D был сломан. Я мог бы быть в состоянии выбрать "Убунту", но он действовал, как я был с помощью Unity в 2D.

Я выяснил, что это связано с OpenGL и я применил эту команду:

1.Удалить драйверы NVIDIA

(Я знаю, что вы не установите никаких драйверов для NVIDIA, я тоже не установить, но в моем случае это были Нвидиа драйверы как-то.)

суда apt-получить продувки от Nvidia*

2.Удаление файла xorg.конф

судо РМ в /etc/Х11/файл xorg.конф

3.Переустановить xorg не полностью

суда apt-получить установку --переустановить пакет xserver-xorg, с-ядро libgl1-Меса-комплектации GLX:i386 в libgl1-Меса-Дри:для i386 libgl1-Меса-комплектации GLX:amd64 в libgl1-Меса-Дри:для amd64

4.Повторно настроить xorg

судо команды dpkg-перенастроить пакет xserver-xorg, с

5.Перезагрузите ваш компьютер

судо перезагрузка

После того, как я применила все эти команды, мое единство 3D вернулся, и когда я проверить информацию о системе, на этот раз с Ubuntu признали мои графики Intel.

+606
sedovlasy 20 дек. 2013 г., 3:12:58

Так в Firefox, я бы смены топ-панель

Просмотра редактирования файлов ... и т. д

и в Фотошопе это будет файл редактировать изображение "выбрать ..." и т. д.

Кроме того, эта функция позволит сделать эти меню баров в окна сами по себе устаревшие, так что мне нужно избавиться от этих.

+563
kent 20 янв. 2016 г., 0:01:57

да что функция уронили!(Я же скучаю), но вы можете использовать суши просмотрщик для то же самое (но это другое)нужно нажать пробел, чтобы просмотреть,преимущество, это превью много медиа-файлов(Музыка,Фото,и т. д..) прочитал эту для более подробной информации

+523
ivanenok 29 авг. 2010 г., 13:41:28

Я не знаю о панели GNOME, но нет-меню что это "особенность" единство.

Тип

суда apt-получить удалить appmenu-GTK по

Затем выйдите из нее и в. Вы должны иметь меню в окне сейчас.

+475
Sniper 5 июл. 2017 г., 7:24:37

Вы можете изменить иконку лаунчера единства размеру, так будет меньше / больше, зависит от того, как вы хотите.

Второй пост в: как я могу настроить единства?

+445
Gabrand 18 июл. 2016 г., 20:10:06

Это действительно вопрос личных предпочтений.

В не-LTS релизы, которые также состоит из некоторые .04 релизы имеют более короткие периоды поддержки, но часто имеют "новые" возможности, которые LTS-релизы не.

Для меня, как правило, обновить себя до последней на мой личный основной ноутбук, перейдите к тестированию на моем ноутбуке тестирования и в зависимости от возможности остаться на LTS для серверов. Для моей работы ноутбук я обычно обновить до последнего, но я не всегда успеваю это сделать сразу после освобождения.

В резюме:

Если вы хотите стабильности и не хотите, долгосрочная поддержка тогда идите с ЛЦ

Если вы хотите режущей кромки, но все-таки стабильный, идут с последней версией

+444
Zoraya Conner 19 нояб. 2018 г., 5:42:38

Сделал новую установку Кетцаль сервер, установлены все обновления. Установленное по умолчанию-JRE и безголовых , которые тянут в пакеты OpenJDK 7 JRE без каких-либо пакеты, связанные с X11. До сих пор так хорошо.

Теперь я пытаюсь установить http://nectar-downloads.cloudbees.com/jenkins-enterprise/1.466/debian/binary/jenkins_1.466.2.1_all.deb (через apt-получить после добавления источника программного обеспечения и apt-получить обновление), чей заголовок по АПТ-кэш показать Дженкинс говорит

Зависит: демон, программы, psmisc, java2-выполнения

Но этого предлагает установить пакеты OpenJDK 6—с GUI!

$ apt-получить -s установить Дженкинс
Следующие новые пакеты будут установлены:
 их режим hicolor-значок-тема состав icedtea-6-JRE и какао состав icedtea-6-JRE и-дисплеи
 состав icedtea-зависящие следующий-следующий-общий Дженкинс libasound2 libasyncns0
 libatk-фантик-Ява libatk-фантик-на Java-JNI, у libatk1.0-0 libatk1.0-данные
 libcairo2 libdatrie1 libflac8 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-общие
 libgif4 libgtk2.0-0 libgtk2.0-ОГРН libgtk2.0-общие libjasper1 libjbig0
 libjson0 libogg0 libpango1.0-0 libpixman-1-0 libpulse0 libsndfile1
 libthai-данные libthai0 libtiff5 libvorbis0a libvorbisenc2 libxcb-render0
 libxcb-shm0 libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxft2 libxi6
 libxinerama1 библиотеке libxml2 libxrandr2 libxrender1 libxtst6 пакеты OpenJDK-6-JRE и
 пакеты OpenJDK-6-JRE и безголовых пакеты OpenJDK-6-JRE и-Либ сояр-база общая-мим-инфо
 ТТФ-дежавю-дополнительные Х11-общий формат XML-ядро

Почему apt-получить не счастлива с Java 7 среда уже установлена и которая предоставляет этот виртуальный пакет?

$ грэп-в наличии-F обеспечивает -s пакет java2-выполнения
Пакет: пакеты OpenJDK-7-JRE и безголовых
Пакет: по умолчанию-среда JRE-безголовый

Даже если я вручную установить недостающие зависимости, демон, похоже, не может заставить apt-получить установку Дженкинс , чтобы не пытаться тянуть в новый Java зависимостей.

Я также попытался загрузить *.Деб и с помощью команды dpkg -я установить его вручную. Но это также терпит неудачу:

с dpkg: проблемы зависимостей предотвратить конфигурации Дженкинс:
 Дженкинс зависит от java2-исполнение; однако:
 Пакет java2-runtime не установлен.

(Примечание: Я намеренно здесь не испытывать Дженкинс пакет во Вселенной, которая имеет разную зависимость список...который, кажется, ведут себя еще хуже.)

+263
CodyKastler 4 авг. 2016 г., 1:27:30

Вам нужно открыть терминал и введите :

судо команды dpkg --настроить -а

Это должно сделать трюк.

+182
Mario S 25 окт. 2017 г., 2:56:09

Вы, наверное, испортил .bashrc и файл и теперь вы не можете открыть терминал больше, так как этот файл используется для настройки оболочки.

  1. Загрузиться в режиме восстановления. Как мне загрузиться в режиме восстановления?

  2. Вашу систему перемонтировать с доступом на запись:

    судо горе -о перемонтировать,РАО /
    
  3. Копия нетронутой .bashrc и файл с файл/etc/скел в своем каталоге, чтобы исправить это. Посмотрим, где первозданная, нетронутая содержимое ~/.профиль файла? (так же ответы .bashrc и), например:

    СР /и т. д/скел/.bashrc и ~имя_пользователя/
    команда chown имя_пользователя: ~имя_пользователя/.bashrc следующее
    
+148
Peavine Consulting 15 апр. 2014 г., 2:18:08

Как предотвратить драйверы Catalyst от увеличения контрастности, если я переключусь с питания на питание от батареи? Одна странность заключается в том, что увеличение контрастности не отображается в настройках драйвера, например если контраст равен 80, то число остается 80, но контраст все-таки прокололся при работе с питанием от батареи. Другая проблема заключается в том, что даже если я потом вручную попробовать уменьшить контраст до 50...60 затем на экране все еще не выглядит достаточно правильно.

+46
jenny 15 мар. 2018 г., 12:29:18

Показать вопросы с тегом